Instalação oracle

DBA Geral (instalação, configuração do banco, scripts do Sql*Plus, shell scripts, batch scripts, etc...)
  

Mensagemem Ter, 09 Nov 2010 2:52 pm

Informações do Ambiente:
* Versão do Oracle:10g
* Sistema Operacional:red hat 7.3
Boa tarde senhores estou quebrando a cabeça e resolvi pedir ajuda aos entendidos no assunto.
Estou tentando instalar o oracle e deu esse problema abaixo:
/home/banco/database/install/.oui: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /home/banco/database/install/.oui)

Segui esse tutorial: http://www.oracle-base.com/articles/10g ... nRHEL5.php
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Ter, 09 Nov 2010 3:22 pm

cara você tera que baixar essa biblioteca no Red Hat, para completar a instalação do Oracle.

Só abrir o terminal e digitar:

Código: Selecionar todos
yum install GLIBC*


Lembrando que você precisará também das bibiotecas:

make
binutils
compat-db
control-center
gcc
gcc-c++
glibc
glibc-common
gnome-libs
libstdc++
libstdc++-devel
pdksh
sysstat
xscreensaver


Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Ter, 09 Nov 2010 3:30 pm

Tentei esse comando e não acha pacote algum, tentei rodar com os debaixo e o yum não acha também cruz credo
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Ter, 09 Nov 2010 3:31 pm

Ta ligado na internet?

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Ter, 09 Nov 2010 3:36 pm

Sim, acho melhor trocar de versão do redhat
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Ter, 09 Nov 2010 3:36 pm

Você poderá baixar os pacotes e instalar pelo:

rpm -i

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Qui, 25 Nov 2010 8:51 am

Instalei no CENTOS 5.5 e foi sem erro até essa parte na figura. Onde configuro?
Imagem

Uploaded with ImageShack.us
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 9:02 am

Ninguém sabe?
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 9:56 am

Se você da ignore ele continua a instalação?

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Sex, 26 Nov 2010 9:58 am

Continua porém fiz isto antes e na hora de startar os serviços nem achava o diretório.
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 10:02 am

Na hora da instalação ele gera um log, o que diz no log?

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Sex, 26 Nov 2010 10:08 am

Não sei onde ficam os logs, você tem msn ou skype?
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 10:20 am

Seriam esses?
[root@redhat ~]# cat /home/oracle/oracle/product/10.2.0/db_1/log/redhat/client/css.log
Oracle Database 10g CRS Release 10.2.0.1.0 Production Copyright 1996, 2005 Oracle. All rights reserved.
2010-11-19 08:15:24.817: [ OCROSD][1564503872]utgdv:2:ocr loc file cannot be opened
2010-11-19 08:15:24.817: [ OCROSD][1564503872]utopen:1: Couldnt find ocr,[ocrmirror] location in config file
2010-11-19 08:15:24.817: [ OCRRAW][1564503872]proprinit: Could not open raw device
2010-11-19 08:15:24.817: [ default][1564503872]a_init:7!: Backend init unsuccessful : [33]
2010-11-19 08:15:24.817: [ CSSCLNT][1564503872]clsssinit: error(33 ) in OCR initialization

2010-11-25 08:40:00.663: [ OCROSD][4158294336]utgdv:2:ocr loc file cannot be opened
2010-11-25 08:40:00.664: [ OCROSD][4158294336]utopen:1: Couldnt find ocr,[ocrmirror] location in config file
2010-11-25 08:40:00.664: [ OCRRAW][4158294336]proprinit: Could not open raw device
2010-11-25 08:40:00.664: [ default][4158294336]a_init:7!: Backend init unsuccessful : [33]
2010-11-25 08:40:00.665: [ CSSCLNT][4158294336]clsssinit: error(33 ) in OCR initialization

E tem outros que ficam no diretório oraiventory/logs
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 10:24 am

Fui ignorando essa mensagem até que no fim deu esta:

Imagem

Uploaded with ImageShack.us
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Sex, 26 Nov 2010 10:40 am

cara você está fazendo uma instalação para um Cluster?

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Sex, 26 Nov 2010 10:42 am

Instalação comun igual neste tutorial

http://www.oracle-base.com/articles/10g ... CentOS.php
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Seg, 29 Nov 2010 10:12 am

Alguma idéia diegopedrao?
diegodcr
Localização: cachoeiro de itapemirim - es

Mensagemem Seg, 29 Nov 2010 10:35 am

Nossa que estranho, nunca tinha visto dar tanto pau assim. Olha um tutorial bom para seguir também é esse aqui.

http://www.vivaolinux.com.br/artigo/Ins ... no-Cent-OS

Vê se esse link te ajuda e se para de dar esses paus...

Att,

Diego Monteiro
diegopedrao
Localização: SP

Mensagemem Seg, 29 Nov 2010 11:23 am

Opa!

Antes de criar a base de dados com o DBCA, faça o seguinte

cd $ORACLE_HOME/rdbms/lib
mv config.o config.o.old

relink oracle

Faça isso aí que eu acredito que resolva, tive esse problema mas não foi com red hat e sim com o suse 10, mas.............

Abraços,
elidias7
Localização: Osasco

Eli Dias
Oracle Certified Professional

Mensagemem Seg, 29 Nov 2010 2:15 pm

diegopedrao fiz igual ao do link e não deu erro até chegar na parte de database configuration que exibe tns lost. Vou seguir com ignore e ver o que da.
diegodcr
Localização: cachoeiro de itapemirim - es



Voltar para DBA Geral

Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 0 visitantes