Erro: ORA-1041 - Problema de conexão/serviço Oracle.

Dúvidas, dicas e truques de PL/SQL. Aqui também vão assuntos relacionados a pacotes, triggers, funções, Java-Stored Procedures, etc
Responder
Tinho
Rank: DBA Sênior
Rank: DBA Sênior
Mensagens: 317
Registrado em: Seg, 16 Nov 2009 4:50 pm
Localização: São Paulo - SP

* Pessoal desculpe, eu deixei a mesma dúvida no tópico DBA, porém não tive resposta, além de poucas visualizações. Não sei se isso se deve ao pouco acesso ao mesmo, ou se ninguém conhece alguma solução. Como eu preciso muito resolver este problema, resolvi postar aqui. Caso o administrador do forum, não autorize, pode deletar e mais uma vez peço as minhas sinceras desculpas.


Informações do Ambiente: *
* Versão do Oracle: oracle xe 10
* Sistema Operacional: windows 7 32 - ultimate
------------------------------------------------------------------------------

Boa noite senhores,

Estou com um erro e não sei mais o que fazer. Um camarada da faculdade me apresentou e eu estava tentando ajudá-lo a resolver, porém sem sucesso. Procurei na internet relatos sobre o mesmo, mais encontrei poucas informações relevantes. Quando derepente aconteceu comigo também! Pasmem do nada, vou relatá-lo.

Tenho o Oracle XE 10 instalado na minha máquina, assim como o Toad e o Erwin, todos funcionando perfeitamente. Como sempre, subo o serviço do Oracle manualmente e uso sem problemas todas as ferramentas, mas hoje, ao tentar criar uma conexão a partir do Erwin, recebi o "fatal" erro:

"ORA-01041: internal error. hostdef extension doesn't exist"

A partir dai, começou o meu suplício.

Continuo fazendo a conexão normalmente através do SQL*PLUS, Toad, porém o meu Erwin "foi pro saco".

As únicas alterações que fiz na minha máquina hoje pela manhã, foi a instalação de algumas ferramentas de DW/BI, pois fui alocado para trabalhar em um cliente através de um consultoria de DW. Não sei, digo, não sei se essas ferramentas podem estar "concorrendo" ou interferindo com algum recurso do Oracle. Por isso, tentei fazer o seguinte:

* Alterar a porta padrão de serviço do Oracle;
* Criar uma string de conexão no "Connection String" do Erwin;
* Reparar a instalação do Oracle;
* Iniciar e Reiniciar os serviços;
* Reiniciei a máquina;

Porém tudo sem sucesso!

Sinceramente amigos, não sei mais o que fazer, por isso, estou recorrendo a vocês em busca de uma ajuda e possível solução.

Obs.: A máquina do meu amigo que está com o mesmo problema não tem nada instalado além do básico.

Se alguém puder me ajudar, fico muito agradecido.

At.
ederphil
Rank: Programador Sênior
Rank: Programador Sênior
Mensagens: 52
Registrado em: Qua, 15 Out 2008 4:05 pm
Localização: taquara-RS

Cara,

já tive um problema parecido no windows 7, no meu caso o problema era o firewal,

ai vai uma definição do amigo Chiappa que foi o que me resolveu,

"01041 é perda de conexão/comunicação,
então supõe-se que você tem algum tipo de conexão com
database "estrangeiro" (não-Oracle), e que essa conexão está sendo
anormalmente interrompida : isso pode ser da rede, pode ser firewall
matando processos inativos, pode ser bug em software (tanto no ODBC
quanto no net8 quanto no soft de comunicação desse
banco "estrangeiro"), muitas variáveis aí...
O procedimento seria mesmo fazer o que a documentação diz : acionar
o Suporte Oracle , e trabalhar com eles - provavelmente eles vão te
instruir a acionar alguns eventos no banco e no net8 que gerem arqs
de trace/log, e vão pedir pra você os enviar, vai ser por aí.

[]s

Chiappa"
Tinho
Rank: DBA Sênior
Rank: DBA Sênior
Mensagens: 317
Registrado em: Seg, 16 Nov 2009 4:50 pm
Localização: São Paulo - SP

Ederphil, muito obrigado.

Vou tentar alguns procedimentos com base nas suas informações.

At.,
Tinho
Rank: DBA Sênior
Rank: DBA Sênior
Mensagens: 317
Registrado em: Seg, 16 Nov 2009 4:50 pm
Localização: São Paulo - SP

Camaradas, aprendi a conviver com este erro em minha máquina e o fato de não conseguir fazer um engenharia reversa conectado ou replicar alterações no Erwin diretamente no banco. Mas ainda, estou em busca de uma possível solução, por isso, encarecidamente gostaria de reavivar este tópico em busca de uma solução.

Grato.
Responder
  • Informação
  • Quem está online

    Usuários navegando neste fórum: Nenhum usuário registrado e 1 visitante